Let's look at the normal error indications from LEDs on a System 6 board:

 

System 6 MPU Board Self Test

(Use of the Diagnostic Button)

 

Both LEDs Flash twice and go out.  Player 1-4 displays go blank, if in game.

This is the correct operation, the self test has passed:

 

Both LEDs come on and stay on when power is first applied, both LEDs remain on when

the diagnostic button is pressed.  Board is locked.  Can be a Flipper ROM failure typically IC14 or IC17, or an unknown fault. 

 

Indicates a ROM failure; one or more of IC14, IC17, IC20, IC21, IC22, or IC26 are faulty:

OFF

ON

 

Indicates RAM failure (IC13 or IC16):

ON

OFF

 

Indicates CMOS RAM (IC19) failure:

ON

ON

 

Procedure Followed

This test was done on two System 7 MPU boards, removing components to simulate them as faulty.

Each time an error was indicated, the test was repeated.  Between tests the component was replaced

Normal operation with a 2x Flash of the "u" on the board's display and from both LEDs was confirmed.

The game was started to the "attract mode" before the next test.

 

On a System 7 board, running System 6 EPROMS:

For a definition of the "Method A" or "Method B" , look at this page.

 

Method A

Default Jumper settings

IC14 = 2716 2K Standard Game (EP)ROM

IC17 = 2532 4K EPROM containing Flipper 1+2 code.

 

IC13 removed (Right 2114 RAM).

Power up = "0" on display + Both LEDs flash once. Then go blank.

Pressing Diags = "2" on display and Top LED ON.

System 6 Indication is correct (IC13 or IC16 is faulty)

 

IC16 removed (Left 2114 RAM)

Power up = "0" remains on display + Both LEDs stay on.

Pressing Diags = "2" on display and Top LED ON.

System 6 Indication is correct (IC13 or IC16 is faulty)

 

IC19 removed (5101 CMOS RAM)

Power up = "0" on display + Both LEDs flash once. Then go blank.

Pressing Diags = "0" on display and Both LEDs ON.

System 6 Indication is correct (IC19 is faulty)

 

IC14 removed (Game EPROM 2716)

Power up = "0" on display + Both LEDs flash once. Then go blank.

Pressing Diags = "E" on display (without the top segment) and Top LED ON.

It does this consistanly,  System 6 indication is wrong.

 

IC17 removed (Flipper 1+2 EPROM 2532)

Power up = "0" remains on display + Both LEDs stay locked on.

Pressing Diags = No change.  Board is locked, no program is running.

It might do anything, but this is the most common result.

 

IC20 removed (Method B only- this is the Flipper 1 EPROM 2716)

Same results as IC17 above, most common result = board locked. Diag does nothing.

 

Better results with error conditions are obtained on by using the 2532 WMS Test ROM in IC17.

Then you can trust the on board display, the numbers are:

0 - Test Passed
1 - IC13 RAM Faulty
2 - IC16 RAM Faulty
3 - IC17 ROM 2 Faulty
4 - IC17 ROM 2 Faulty
5 - IC20 ROM I Faulty
6 - IC14 Game ROM 1 Faulty
7 - IC26 Game ROM 0 Faulty
8 - IC19 CMOS RAM or memory protect circuit faulty
9 - Coin-door closed, memory protect circuit faulty, or IC19 CMOS RAM Faulty.